Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

AlessandroVespignani.isi

 

Time frame:

1990-2006

Region(s):

Indiana University, University of Rome, Yale University, Leiden University, International Center for Theoretical Physics, University of Paris-Sud

Topical Area(s):

Informatics, Complex Network Science and System Research, Physics, Statistics, Epidemics

Analysis Type(s):

Co-Authorship Network

The Sci2 Tool supports the analysis of evolving networks. For this study, load Alessandro Vespignani's publication history from ISI, which can be downloaded from Thomson's Web of Science or loaded using 'File > Load' and following this path: 'yoursci2directory/sampledata/scientometrics/isi/AlessandroVespignani.isi'using' (if the file is not in the sample data directory it can be downloaded from 2.5 Sample Datasets).

Panel
New ISI File Format

Web of Science made a change to their output format in September, 2011. Older versions of Sci2 tool (older than v0.5.2 alpha) may refuse to load these new files, with an error like "Invalid ISI format file selected."

Sci2 solution

If you are using an older version of the Sci2 tool, you can download the WOS-plugins.zip file and unzip the JAR files into your sci2/plugins/ directory. Restart Sci2 to activate the fixes. You can now load the downloaded ISI files into the Sci2 without any additional step. If you are using the old Sci2 tool you will need to follow the guidelines below before you can load the new WOS format file into the tool.

You can fix this problem for individual files by opening them in Notepad (or your favorite text editor). The file will start with the words:

Original ISI file:

Just add the word ISI.

Updated ISI file:

And then Save the file.

The ISI file should now load properly. More information on the ISI file format is available here (http://wiki.cns.iu.edu/display/CISHELL/ISI+%28*.isi%29).

Slice the data into five year intervals from 1990-2006 using 'Preprocessing > Temporal > Slice Table by Time' and the following parameters:

"Slice Into" allows the user to slice the table by days, weeks, months, quarters, years, decades, and centuries. There are two additional parameters for time slicing: cumulative and align with calendar. The former produces tables containing all data from the beginning to the end of each table's time interval, which can be seen in the Data Manager and below:

The latter option aligns the output tables according to calendar intervals:


Choosing "Years" under "Slice Into" creates multiple tables beginning from January 1st of the first year. If "Months" is chosen, it will start from the first day of the earliest month in the chosen time interval.

To see the evolution of Vespignani's co-authorship network over time, check "cumulative". Then, extract co-authorship networks one at a time for each sliced time table using 'Data Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up window during the extraction.  To view each of the Co-Authorship Networks over time using the same graph layout, begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under 'slice from beginning of 1990 to end of 2006 (101 records)') in the data manager. Visualize it in GUESS using 'Visualization > Networks > GUESS'. From here, run 'Layout > GEM' followed by 'Layout > Bin Pack'.  Run 'Script > Run Script ...' and select ' yoursci2directory/scripts/GUESS/co-author-nw.py'.

The resulting visualization is of the complete co-authorship network over all years. Use Node Locking to save the x, y coordinates of each node and apply them to the other time slices. In GUESS, select 'File > Export Node Positions' and save the result as 'yoursci2directory/NodePositions.csv'. Load the remaining three networks in GUESS using the steps described above and for each network visualization, run 'File > Import Node Positions' and open 'yoursci2directory/NodePositions.csv'. To match the resulting networks stylistically with the original visualization, run 'Script > Run Script ...' and select ' yoursci2directory/scripts/GUESS/co-author-nw.py', followed by 'Layout > Bin Pack', for each. The evolving network is shown in Figure 5.4.


Figure 5.4: Evolving co-authorship network of Vespignani from 1990-2006
The four networks reveal that from 1988-1992, Alessandro Vespignani had one primary co-author and four secondary co-authors. His network expanded considerably to include multiple primary co-authors and more than 200 secondary co-authors in 2006.

To see the log file from this workflow save the 5.1.2 Time Slicing of Co-Authorship Networks (ISI Data) log file.