Child pages
  • 2.4 Saving Visualizations for Publication

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Once you have finalized your visualization in GUESS you will need to export the image. Go to "File > Export Image..." and select the location where you want to save the document. Then you will want to choose the file type, in this case PDF. Finally, you can rescale the image by selecting export complete graph and setting a different value for the rescale image parameter:

Image RemovedImage Added

This will output an image 55402px 56060px by 59205px39226px. In this case we are creating a very large image, but you can rescale the image to your desired size.

...

Select the file PDF you saved and click open :

Image Removed

This and this will load your network visualization in Inkscape.

...

Adjust the height and width of the document to help your visualization fit better:

Image RemovedImage Added

2.4.2.5 Ungrouping the Visualization

...

Info

In order to determine the values for our symbols we will need to refer back to the original visualization. In GUESS you can use the information window to view these values. Simply hover your mouse over the node or edge you wish to examine and view its properties in the information window:

To find the values for attributes of nodes and edges in Gephi, view the graph in the Overview window of Gephi. Then use the Image Removed the Image Added tool and label the edges and the nodes:Image Removed

Image Added

Once you have chosen which attribute to label the nodes or edges with they can be applied by clicking the label tool: Image RemovedImage Added . It is a good idea to label nodes and edges separately. In other words, apply the node labels and then remove them before you apply the edge labels. Otherwise, the graph will be too crowed with node and edge labels to identify values to use in your legend. Typically, it can be difficult to identify edge attribute values because there are so many edges to be labeled that it can become crowded very quickly. One trick when dealing with a lot of attribute labels is to use the Gephi filters to filter either nodes or edges by certain attributes. To pull up the filter window in Gephi go to "Window > Filters" at the top of the tool:Image Removed

Image Added

The filter window will appear at the right-hand side of the tool. You can choose to filter edges by the edge weight (number of co-authored papers) attribute by dragging the edge weight filter into the queries section below:

Image RemovedImage Added

Use the slide bar at the very bottom of the window to filter the edges. Drag the bar and then click filter:

Image RemovedImage Added

To create the symbols in the legend, we will be using differently sized circles (representing nodes) to convey the wealth of the families in this network.

...

When the you have created the symbols for the nodes you may need to change the stroke and fill colors so that all the symbols are the same. To change the stroke color and the fill color for any object in the graph simply use the selection tool: Image Removed  Image Added to identify the object and then select "Object > Fill and Stroke..." in the tool menu. This will bring up the pallet you need to edit the fill and stroke for objects:Image Removed

Image Added

The next step will be to create a gradient scale for the color of  the nodes. Using the rectangle tool:  Image Removed   Image Added create a rectangle below the node symbols:

...

Now we need to fill each rectangle with the range of colors we applied to the nodes and the range of colors we applied to the edges, respectively. Select the first rectangle, under the Node Size & Color title. You will notice that in the fill tab there is the option to fill an object using a linear gradient:

Image RemovedImage Added

Once you have selected the linear gradient, make sure the rectangle tool: Image Removed  Image Added is select and the rectangle should appear like this:Image Removed

Image Added

Select the square at the left-side of the blue line:

 

Image RemovedImage Added

Then use the eyedropper tool: Image Removed  Image Added and select the color from a node at the lowest limit of the scale, the Pucci family node. Repeat this process, select the circle at the right-side of the blue line and use the eyedropper tool to select the color from the largest node, the Strozi family:

...

The next step is to create two symbols below the "Edge Color" title to represent the two types of relationships in this network. Use the rectangle Image Removed rectangle Image Added tool to create the symbols:

...

The final step is to label your symbols in your legend using the Image Removed the Image Added text tool:

 

The resulting visualization will look something like this:

...