Child pages
  • 2.4 Saving Visualizations for Publication

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

2.4.1 Saving Files from the Data Manager

The Sci2 Sci2 Tool supports various image output formats. When in GUESS, use 'File> Export Image' to export the current view or the complete network in diverse file formats such as jpg, png, raw, pdf, gif, etc.
To save image files created outside of GUESS, such as Circular Hierarchies or Geospatial Visualization, right-click on the PostScript file in the data manager and then click 'save'. Select 'PostScript' and then save the file to your desired directory.

...

2.4.2 Creating Legends for Visualizations

Watch the video of this workflow:


Widget Connector
urlhttp://www.youtube.com/watch?feature=player_embedded&v=DiKK6hcRp08


2.4.2.1 Saving Visualizations from GUESS

...

This will output an image 56060px by 39226px. In this case we are creating a very large image, but you can rescale the image to your desired size. Make sure to leave GUESS open on your machine because you may need to refer back to the original graph while creating legend!

...

When the PDF is opened in Inkscape all of the various components of the visualization, in this case nodes, edges, and labels, will be grouped together. The next step will be to ungroup those components so you can access and edit them individually. To perform an ungroup, first left-click on the graph so the entire image is selected:

...

Also, some of the labels may appear behind the nodes and the edges, making them difficult to read. If this is the case you can bring the label to the front. Select the label you wish to bring to the front by clicking on it. Then from the menu at the top select "Object > Raise to Top"

Image RemovedImage Added

Look over the entire graph and make sure all your labels are clearly visible. You may need to refer back to the visualization in GUESS or Gephi to check the labels for certain nodes and make sure all the nodes accurately labeled. If you need to edit existing label text you can do so by selecting the Create and Edit Text Objects tool : Image Removed icon from the tool menu on the left-hand side of the screen or by hitting the F8 key. When using this tool click on the label you wish to edit and change the text.

...

The next step is to begin creating your legend. How you create the legend depends on the values for attributes of the nodes and edges in your network. This is the information you want to convey to those who see your visualization. In the following steps we will be working with the network we generated from the florentine.nwb file in section 2.7 8 Visualizing Data with Sci2 on the Sci2 wiki . As you may remember, the nodes have been sized based on the wealth of the family represented by the node and colorized based on the number of priorates a particular family held. The edges have been colorized based on the type of relationship that connects two families: business tie or marriage. So, based on these attributes we are going to create titles and subtitles for our legend:

...

Using the Create and Edit Text Objects tool: Image Removed  Image Added you can create titles. For each section of text that you want to display a different font size and color, for example the subtitles, you will need to create a separate text object. If you want to edit the text you can use the tool bar at the top of the tool:

Image RemovedImage Added

With this toolbar you can change the font and size of the text, as well as other attributes. If  you want to change the color of the text you can do so by using the color pallet at the bottom of the tool:

Image RemovedImage Added

2.4.2.8 Creating Legend Symbols

...

Info

In order to determine the values for our symbols we will need to refer back to the original visualization. In GUESS you can use the information window to view these values. Simply hover your mouse over the node or edge you wish to examine and view its properties in the information window:

Image RemovedImage Added==--

To find the values for attributes of nodes and edges in Gephi, view the graph in the Overview window of Gephi. Then use the  tool and label the edges and the nodes:

Once you have chosen which attribute to label the nodes or edges with, they can be applied by clicking the label tool: . It is a good idea to label nodes and edges separately. In other words, apply the node labels and then remove them before you apply the edge labels. Otherwise, the graph will be too crowed with node and edge labels to identify values to use in your legend. Typically, it can be difficult to identify edge attribute values because there are so many edges to be labeled that it can become crowded very quickly. One trick when dealing with a lot of attribute labels is to use the Gephi filters to filter either nodes or edges by certain attributes. To pull up the filter window in Gephi go to "Window > Filters" at the top of the tool:

The filter window will appear at the right-hand side of the tool. You can choose to filter edges by the edge weight (number of co-authored papers) attribute by dragging the edge weight filter into the queries section below:

Use the slide bar at the very bottom of the window to filter the edges. Drag the bar and then click filter:

...

Once you have identified these nodes you can select them in the Inkscape file:

==

It is helpful to zoom in on the image and make sure you are actually selecting the border around the node. Once you have made the selection, copy the selection by right-clicking and copying the selection (or by using the Ctrl+C keyboard shortcut). Then paste the copy below the first title "Nodes Size & Color."

Image Removed

If you are unable to accurately copy and paste the circles from the network you can create your own using the circle tool and manually creating the symbols:

...

Then use the eyedropper tool:  and select the color from a node at the lowest limit of the scale, the Pucci family node. Repeat this process, select the circle at the right-side of the blue line and use the eyedropper tool to select the color from the largest node, the Strozi family:

Image RemovedImage Added

The next step is to create two three symbols below the "Edge Color" title to represent the two three types of relationships in this network. Use the rectangle  tool to create the symbols:

Image RemovedImage Added

The final step is to label your symbols in your legend using the  text tool:

Image RemovedImage Added

 

The resulting visualization will look something like this:

Image RemovedImage Added

 

Now you have created a legend for this visualization! A person who sees your visualization will now be better able to understand exactly what information is meant to be conveyed with this visualization. Feel free to think of other ways to convey the information about the various attributes of you visualization.

...