Child pages
  • Eclipse development setup for CIShell and Sci2
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 7 Next »

Introduction

This document will walk you through installing Eclipse, installing and configuring necessary plugins, pulling all the necessary source code, and even building both CIShell and Sci2. This process is only necessary if you plan on doing advanced development on the CIShell platform or Sci2 core plugins. If you are developing or modifying a single plugin, refer to this tutorial instead. This tutorial will be presented in steps, and assumes you already have the most recent version of the Java 7 64-bit JDK installed.

Setup

Install and launch Eclipse

The first thing you'll need to do is acquire Eclipse, if you don't already have it. The Eclipse.org website is the official source for these downloads. In this case, we will be installing the latest version, Eclipse Kepler. It is recommended to download the Eclipse Standard Package. If you have the Java 64-bit JDK, you will want to download the 64-bit version of Eclipse. Extract the contents of the .zip download, which should consist of a folder called eclipse. Place the folder wherever you would like, change the name if you wish, then open up eclipse.exe contained in the folder. Eclipse will ask you to select a workplace, so either accept the default location or select a custom directory. When Eclipse opens for the first time, you should see a welcome screen, which you can close.

Note:

We recommend placing your Eclipse workplace on a Solid State Drive (SSD), if you have one, since it will make the application much faster when performing various tasks.

Install and configure Eclipse plugins

EGit

EGit should be included in all Eclipse Standard packages. To double check, you can click on Help->About Eclipse from the Eclipse toolbar. EGit should be one of the plugins listed.

Subclipse

To install Subclipse, you'll want to go to Help->Install New Software... from the Eclipse toolbar.

  1. In the Work with: field, paste the following URL: http://subclipse.tigris.org/update_1.8.x
    1. Note: The newest version of Subclipse, such as 1.10.x, do not currently work with plugins we will install later on
  2. Click on the Add... button to the right of that field

  3. Give a descriptive name to this new repository, such as Subclipse

  4. After fetching data from the repository, two top level results should appear. Check the boxes to the left of Subclipse and SVNKit then click Next

  5. Click Next again, accept the terms of the license agreement, then click Finish

  6. Eclipse will now install Subclipse. It may ask to be restarted - go ahead and agree to that so that the installation can complete 

Maven Integration (m2eclipse)

To install m2eclipse, you'll want to go to Help->Install New Software... from the Eclipse toolbar.

  1. In the Work with: field, paste the following URL: http://download.eclipse.org/technology/m2e/releases
  2. Click on the Add... button to the right of that field
  3. Give a descriptive name to this new repository, such as m2eclipse
  4. After fetching data from the repository, a single top level result should appear. Check the box to the left of Maven Integration for Eclipse, then click Next
  5. Click Next again, accept the terms of the license agreement, then click Finish
  6. Eclipse will now install m2eclipse. It may ask to be restarted - go ahead and agree to that so that the installation can complete 

Add m2eclipse Connectors

The Maven integration software requires two connectors for Git and Subversion before we can start pulling code and importing projects with Maven. We will now install those connectors.

egit Handler
  1. Go to File->Import... from the Eclipse toolbar
  2. Select Maven->Check out Maven Projects from SCM and then click Next
  3. Near the bottom of this window, where it says Find more SCM connectors in the m2e Marketplace, click the blue link
  4. In the window that opens, in the Find: field, type in egit. The first result should be m2e-egit - check the box next to that entry and click Finish
  5. After some processing, another window should pop up. The Maven SCM Handler should be checked, so you can just click Next here
  6. Click Next on the following screen, then accept the license agreement and click Finish
  7. A security warning might pop up, just click OK
  8. A dialog will prompt you to restart Eclipse - click Yes
 
Subclipse Handler
 
  1. Go to File->Import... from the Eclipse toolbar
  2. Select Maven->Check out Maven Projects from SCM and then click Next
  3. Near the bottom of this window, where it says Find more SCM connectors in the m2e Marketplace, click the blue link
  4. In the window that opens, in the Find: field, type in subclipse. The first result should be m2e-subclipse - check the box next to that entry and click Finish
  5. After some processing, another window should pop up. The Maven SCM Handler should be checked, so you can just click Next here
  6. Click Next on the following screen, then accept the license agreement and click Finish
  7. A security warning might pop up, just click OK
  8. A dialog will prompt you to restart Eclipse - click Yes
 

Note:

For whatever reason, SVN and the SVN connector will not work until you make this change:

  1. After Eclipse has been restarted, go to Window->Preferences from the toolbar
  2. In the search field in the top left corner, type in SVN, then click on the SVN header
  3. In this options screen, under SVN interface, select SVNKit (Pure Java) for Client
  4. Click OK to exit Preferences and save changes

test

  • No labels